Search…
Getting started
Get up and running quickly with Govern as a Developer.
The Govern project consists of several sub-projects interacting with each other. The Aragon Govern product can be found here: https://govern.aragon.org/​

Contracts

The contracts are split in two projects: erc3k (the interfaces defining the ERC3000 standard), and govern-core (the Aragon Govern contracts, implementing ERC3000).
Relevant packages:

Govern Console

The Aragon Govern Console is a no-frills, forkable, extensible power user / developer UI tool for interacting with and visualizing low level information about Govern DAOs.
The Aragon Govern Console
Relevant packages:

Govern Server and Govern.js

Govern Server acts as a central point, fetching data from different sources (Ethereum, the Govern subgraph, IPFS) and providing it as a unified API to consumers.
You can use it through the Govern.js library, or through its GraphQL API. It is powered by The Graph.
Govern Server and how it relates to the other projects
Relevant packages:
WARNING
Aragon Govern is beta software which is NOT MAINTAINED anymore. It's a really cool product though with innovative and nifty smart contracts. So although you might run into an error 🐲 here and there, the documentation is definitely worth the read and the play!
And welcome to connect with us through Discord or our technical forum!

Run Aragon Govern Console locally:

The recommended Node version to run this is: node v14. You might run into unwanted errors with a lower or higher version.
Start by cloning the Govern repository on your local machine:
git clone https://github.com/aragon/govern.git
The continue by bootstrapping the entire monorepo with yarn:
cd govern
yarn
The yarn command might give a: gyp ERR! build error.The next step should work however.
This will install all needed dependencies, and link all packages together to make sure you're using the local version of each one. Now it's time to install dependencies of the @aragon/govern package and to create a build:
cd packages/govern
yarn
yarn build
Now we are prepared to give Govern Console a run:
cd ..
cd govern-console
yarn
No to prevent a 'babel version error' from happening, create a .env file in the root of the govern-console folder, add the following line and then save the file:
SKIP_PREFLIGHT_CHECK=true
Now we are really ready to spin up the @aragon/govern-console package:
yarn start
It is time to call out your victory
πŸŽ‰
, if you see a page like the below appear in your browser:
Copy link
On this page
Contracts
Govern Console
Govern Server and Govern.js
Run Aragon Govern Console locally: